Blog Details

Zest LogicWooCommerce updated PHP requirements in an upcoming version.
zlogicmaster January 10, 2022
Photo by Wolfgang Hasselmann on Unsplash

A few days ago, WooCommerce announced that the upcoming version, 6.5, which will be released in May, will have updated PHP requirements. To work properly, the new version will need PHP 7.2 or newer. The stores operating on the older PHP versions won’t upgrade past 6.4.

This is an important update, and it is worth mentioning that WooCommerce rarely makes such updates. For example, a previous change of the version requirements happened about three years ago – in January 2019 when WooCommerce 3.9 was released. At that moment, they set the required version to 7.0.

Currently, PHP 8.0 and 8.1 are in active maintenance. Although older versions are still being used, they do not receive many updates. For example, PHP 7.4 is getting only security fixes.

PHP 7.3 and 7.2 are not updated anymore, so they can’t be recommended to be used due to security reasons which are crucial for an eCommerce website. Another reason is the variety of third-party packages used by many web stores to get more features. Many of them already dropped support for older PHP versions, so the store owners who use PHP 7.0 struggle to get the package that contains the functions they need and is compatible with this outdated version of the language.

However, WooCommerce decided not to drop the whole branch of PHP 7 because many stores are still using it. According to their data, around 20 thousand stores are still using 7.2,  

about 60 thousand – 7.3 and 182 thousand – 7.4. Older versions (7.1 and 7.0) counted together are installed in less than 10 thousand websites. The stores with the newer versions (8.x) are currently less widespread than those with 7.2, but no doubt, their part will increase in the future.